VS:CreateClassPullDownMenu/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

クラスのプルダウンメニューを作成します。

PROCEDURE CreateClassPullDownMenu(
nDialogID :LONGINT;
nComponentID :LONGINT;
nWidthInChars :INTEGER);
def vs.CreateClassPullDownMenu(nDialogID, nComponentID, nWidthInChars):
    return None

Parameters

nDialogID LONGINT
nComponentID LONGINT
nWidthInChars INTEGER

Example

PROCEDURE Example;
VAR
   dialog1 :INTEGER;
   result  :INTEGER;
PROCEDURE Dialog_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
END;
BEGIN
   dialog1 := CreateLayout('Example Dialog', FALSE, 'OK', 'Cancel');
   CreateClassPullDownMenu(dialog1, 4, 24);
   SetFirstLayoutItem(dialog1, 4);
   result := RunLayoutDialog(dialog1, Dialog_Handler);
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks 2008

See Also

関連関数:

VS:CreateImageControl

関連関数: [[VS:CreateImageControl]]