VS:ColorIndexToRGBN/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

カラーパレットの色番号から各色の成分を取り出します。値の範囲は0から65535までです。ignoreBlackBackgroundパラメータは背景色を黒にする設定を無視するか否かを設定します。TRUEに設定すると、白と黒のインデックスは背景色が黒であっても逆にされません。


A color table listing with associated index values can be found in the <A HREF="../Appendix/appendix.html#colors">Appendix</A>.

PROCEDURE ColorIndexToRGBN(
color :INTEGER;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT;
ignoreBlackBackground :BOOLEAN);
def vs.ColorIndexToRGBN(color, ignoreBlackBackground):
    return (red, green, blue)

Parameters

color INTEGER 色番号
red LONGINT 赤の成分
green LONGINT 緑の成分
blue LONGINT 青の成分
ignoreBlackBackground BOOLEAN 背景色を黒にする設定を無視する設定

Example

ColorIndexToRGBN(257,r,g,b,TRUE);
{returns the color value components of the color index 257 (black)}
{Because ignoreBlackBackground is set to TRUE, the result }
{will always be black RGB color regardless of the black background }{preference setting.}

Version

利用可能バージョン: Vectorworks 2010