VS:ClosestPoints
From Vectorworks Developer
.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix
Description
Returns the points on two objects where the shortest distance between those objects occurs. Should support all VW primitives, including polylines and NURBS. Would be nice if it supported groups, symbols, and PIOs. Would also be nice if it supported 3D.PROCEDURE ClosestPoints(
h1 :HANDLE;
h2 :HANDLE;
VAR pt1 :VECTOR;
VAR pt2 :VECTOR;
VAR touching :BOOLEAN);
def vs.ClosestPoints(h1, h2): return (pt1, pt2, touching)
Parameters
h1 HANDLE h2 HANDLE pt1 VECTOR pt2 VECTOR touching BOOLEAN