VS:CircularDim/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

半径、直径の寸法線を作成します。

PROCEDURE CircularDim(
startPt :REAL;
endPt :REAL;
box1 :REAL;
box2 :REAL;
textOffsetDistance :REAL)Coordinate); dimType:INTEGER; arrow:INTEGER; textFlag:INTEGER; shoulder:REAL);
def vs.CircularDim(startPt, endPt, box1, box2, textOffsetDistance, dimType, arrow, textFlag, shoulder):
    return None

Parameters

startPt REAL 始点の座標
endPt REAL 終点の座標
box1 REAL 測定開始点の座標
box2 REAL 測定終了点の座標
textOffsetDistance REAL (Coordinate) オフセット
dimType INTEGER 寸法の種類
arrow INTEGER マーカの種類
textFlag INTEGER 文字の種類
shoulder REAL 寸法線と寸法値の間隔

Example

CircularDim(-4 3/8",3",-4 3/8",1/4",-5 3/4",3",-3",1/4",1 1/8",1,3, 1025,1/4");

Version

利用可能バージョン: MiniCAD