VS:Angle

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the angle value of a line segment or an arc. If more than one line segment or arc matches the search criteria, the function will return the sum of the matching objects' angle values.

FUNCTION Angle(
c :CRITERIA) : REAL;
def vs.Angle(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Return Value

If an object matches the search criteria but is not a line segment or an arc, the value 0(zero) is returned.

Example

VectorScript

aValue:=Angle(N='LineSeg');

Python


Version

Availability: from All Versions