VS:AddVectorFillLayer/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハッチングに線を追加します。

PROCEDURE AddVectorFillLayer(
xStart :REAL;
yStart :REAL;
xRepeat :REAL;
yRepeat :REAL;
xOffset :REAL;
yOffset :REAL;
dashFactor :REAL;
lineWeight :INTEGER;
colorIndex :INTEGER);
def vs.AddVectorFillLayer(xStart, yStart, xRepeat, yRepeat, xOffset, yOffset, dashFactor, lineWeight, colorIndex):
    return None

Parameters

xStart REAL 始点のX座標
yStart REAL 始点のY座標
xRepeat REAL 終点のX座標
yRepeat REAL 終点のY座標
xOffset REAL 間隔の水平オフセット
yOffset REAL 間隔の垂直オフセット
dashFactor REAL 倍率
lineWeight INTEGER 線の太さ
colorIndex INTEGER 線の色番号

Example

PROCEDURE CreateHatch;
VAR
	hatchName :STRING;
BEGIN
	hatchName := 'My New Hatch';
	BeginVectorFillN(hatchName, TRUE, FALSE, 0);
	AddVectorFillLayer(0, 0, 1, 1, 0.1767767, -0.1767767, 1, 1, 255);
	EndVectorFill;
END;
RUN(CreateHatch);

Version

利用可能バージョン: MiniCAD7.0.1