VS:AddToPIOStyleEdit

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds an item to a plug-in style's default edit list. This is only used by objects that use the default edit style dialog.


By default, only those parameters shown in the object info palette will be listed in the edit style mapping dialg. Pass the following values to add or remove an item this list.

Values:
1 - Add to the edit style map dialog.
2 - Remove from the edit style map dialog.


To remove an entry from this list use RemovePIOStyleEdit.

FUNCTION AddToPIOStyleEdit(
hObj :HANDLE;
keyName :STRING;
editType :INTEGER;
displayName :STRING) : BOOLEAN;
def vs.AddToPIOStyleEdit(hObj, keyName, editType, displayName):
    return BOOLEAN

Parameters

hObj HANDLE Handle to a plug-in object or plug-in object style
keyName STRING Universal name of parameter or other item to add to the edit style map list
editType INTEGER 1 - Add to edit list 2 - Remove from edit list
displayName STRING The display name to use in the style map dialog. If an empy string is passed the keyName will be used.

Return Value

TRUE if key is added to the list.


FALSE if hObj is NULL; if hObj is not a styled plug-in object or plug-in style
FALSE if item already appear in list. Use RemoveFromPluginStyleEditList first.

Version

Availability: from Vectorworks 2018

See Also

VS Functions:

VS:RemovePIOStyleEdit

VS Functions: [[VS:RemovePIOStyleEdit]]