VCOM:VectorWorks:Workspaces:IWorkspaces

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Interface

static const VWIID IID_Workspaces = { 0xBD71F2D6, 0x8C66, 0x4D21, { 0xA6, 0x13, 0x3A, 0x92, 0xD7, 0x52, 0x99, 0x45 } };
		
class IWorkspaces : public IVWUnknown
{
public:
  virtual VCOMError VCOM_CALLTYPE CreateIdentifierUsingResourceID(EWorkspaceItemType inItemType, Sint16 inResourceID, TXString& outIdentifier) = 0;
  virtual VCOMError VCOM_CALLTYPE CreateIdentifierUsingUniversalName(EWorkspaceItemType inItemType, const TXString& inUniversalName, TXString& outIdentifier) = 0;
  virtual VCOMError VCOM_CALLTYPE CreateIdentifier(EWorkspaceItemType inItemType, TXString& outIdentifier) = 0;
  virtual VCOMError VCOM_CALLTYPE ConvertStringToSafeXMLFormat(TXString& ioString) = 0;
  virtual VCOMError VCOM_CALLTYPE ConvertSafeXMLFormatToString(TXString& ioString) = 0;
  virtual VCOMError VCOM_CALLTYPE GetIcon(const TXString& inIdentifier, VectorWorks::UI::IIcon* outIcon) = 0;
  virtual VCOMError VCOM_CALLTYPE GetDisplayName(const TXString& inIdentifier, TXString& outDisplayName) = 0;
};

Members

CreateIdentifierUsingResourceID Using the given Resource Manager ID, creates the workspace identifier.
CreateIdentifierUsingUniversalName Using the given Universal Name, creates the workspace identifier.
CreateIdentifier Using the given workspace item type, creates a unique workspace identifier.
ConvertStringToSafeXMLFormat Converts a string to one that will be safe to store in the XML file.
ConvertSafeXMLFormatToString Converts a xml-safe string to its original, normalized state.
GetIcon Gets the image data (encoded as a PNG) and size given the Workspace Identifier.
GetDisplayName Gets the item's display/localized name given the Workspace Identifier.

Remarks

The different graphical user interface items that appear in the workspace and can be managed.

enum EWorkspaceItemType {
  eWorkspaceItemType_MenuItem,
  eWorkspaceItemType_MenuChunk,
  eWorkspaceItemType_Menu,
  eWorkspaceItemType_Tool,
  eWorkspaceItemType_ToolSet,
  eWorkspaceItemType_ToolPalette
};

Error codes returned from Workspace interfaces:

  enum EWorkspacesError {
  eWorkspacesError_NoError,
  eWorkspacesError_UnknownError,
  eWorkspacesError_InvalidArg,
  eWorkspacesError_WorkspaceNotOpen,
  eWorkspacesError_WorkspaceAlreadyOpen,
  eWorkspacesError_WorkspaceAlreadyExists,
  eWorkspacesError_WorkspaceNotFound,
  eWorkspacesError_WorkspaceNotReadable,
  eWorkspacesError_WorkspaceNotReadWritable,
  eWorkspacesError_BadArrayIndex,
  eWorkspacesError_ElementNotFound
};

Version

Available from: VectorWorks 12

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]