VCOM:VectorWorks:UI:IInfoBar::IncrementProgressIndicator

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IInfoBar

Moves the progress indicator with the specified amount.

virtual VCOMError VCOM_CALLTYPE IncrementProgressIndicator(
Uint16 nProgress) = 0;
virtual VCOMError VCOM_CALLTYPE IncrementProgressIndicator(
Uint16 nProgress,
const TXString& strProgressLabel) = 0;

Parameters

nProgress Uint16 Increment the progress indicator with this value.
strProgressLabel const TXString& The new progress label text.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.