VCOM:VectorWorks:UI:IIcon::IsSet

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IIcon

Check if there is an icon set in this instance.

virtual VCOMError VCOM_CALLTYPE IsSet(
bool& outResult) = 0;

Parameters

outResult bool& Output parameter. Return boolean if there is an icon set into this instance.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.