VCOM:VectorWorks:UI:IIcon::GetNativeIcon

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IIcon

Returns native OS handle to the icon represented by this instance.

virtual VCOMError VCOM_CALLTYPE GetNativeIcon(
void*& handle) = 0;

Parameters

handle void*& Output parameter. Native OS handle to the icon.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.