VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider::SetWidget

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::PluginSupport

Member of VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider

Set widget data. For widget types see SDK:SWidgetDefinition#Remarks

virtual bool SetWidget(
size_t index,
Sint32 widgetID,
EWidgetType widgetType,
const TXString& localizedName) = 0;

Parameters

index size_t Zero based index to the widget in the list.
widgetID Sint32 The widget identifier. This must be unique for all widgets in this interface.
widgetType EWidgetType The widget type.
localizedName const TXString& Localized name that will appear next to the widget.