VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider::AddWidget

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::PluginSupport

Member of VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider

Add a new widget to the instance. For widget types see SDK:SWidgetDefinition#Remarks

virtual void AddWidget(
Sint32 widgetID,
const TXString& paramName) = 0;
virtual void AddWidget(
Sint32 widgetID,
const TXString& paramName,
const TXString& localizedName) = 0;
virtual void AddWidget(
Sint32 widgetID,
EWidgetType widgetType,
const TXString& paramName,
const TXString& localizedName) = 0;
virtual void AddWidget(
Sint32 widgetID,
EWidgetType widgetType,
const TXString& localizedName) = 0;

Parameters

widgetID Sint32 The widget identifier. This must be unique for all widgets in this interface.
widgetType EWidgetType The widget type.
paramName const TXString& Parameter name of the object's Prm# resource parameter.
localizedName const TXString& Localized name that will appear next to the widget. If empty and used with 'paramName' then the object's Prm# resource parameter localized name is taken.