VCOM:VectorWorks:PluginSupport:IExtendedProps::SetObjComponentTypeDefLineWeight

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::PluginSupport

Member of VCOM:VectorWorks:PluginSupport:IExtendedProps

No info.

virtual VCOMError VCOM_CALLTYPE SetObjComponentTypeDefLineWeight(
CodeRefID inCodeRefID,
TComponentTypeID typeID,
Sint16 lineWeight,
bool bByClass) = 0;

Parameters

inCodeRefID CodeRefID
typeID TComponentTypeID
lineWeight Sint16
bByClass bool

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.