VCOM:VectorWorks:PluginSupport:IExtendedProps::GetObjComponentTypeDefFillPat

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::PluginSupport

Member of VCOM:VectorWorks:PluginSupport:IExtendedProps

No info.

virtual VCOMError VCOM_CALLTYPE GetObjComponentTypeDefFillPat(
CodeRefID inCodeRefID,
TComponentTypeID typeID,
InternalIndex& outObjIndex,
bool& bOutByClass) = 0;

Parameters

inCodeRefID CodeRefID
typeID TComponentTypeID
outObjIndex InternalIndex& Output parameter.
bOutByClass bool& Output parameter.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.