VCOM:VectorWorks:ISDK::WSAddToolSet

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

@param inToolSetIdentifier the tool set we are adding to the workspace.

@param inIconData the memory containing the icon data.

@param inIconDataSize the size of the memory in inIconData.

@return true if the operation was successful.

virtual bool WSAddToolSet(
long inWorkspaceReference,
const TXString& inToolSetIdentifier,
void* inIconData,
Uint32 inIconDataSize)

Parameters

long inWorkspaceReference No information available.
constTXString& inToolSetIdentifier No information available.
void* inIconData No information available.
Uint32 inIconDataSize No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009