VCOM:VectorWorks:ISDK::SetWorksheetCellFill

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets specified fill style and color in specified worksheet cells.


Fill style constants: 0 for NO FILL, 1 for SOLID FILL , 2 for PATTERN FILL

bgcolor - cell background color (0 if none)

fgcolor - cell foreground color (0 if none)

fillpattern - cell fill pattern index (-1 if none)

virtual void SetWorksheetCellFill(
MCObjectHandle worksheet,
const Point& topLeftCell,
const Point& bottomRightCell,
short style,
ColorRef bgcolor,
ColorRef fgcolor,
short fillpattern)

Parameters

MCObjectHandle worksheet No information available.
constPoint& topLeftCell No information available.
constPoint& bottomRightCell No information available.
short style No information available.
ColorRef bgcolor No information available.
ColorRef fgcolor No information available.
short fillpattern No information available.

Version

Availability: from Vectorworks 2009