VCOM:VectorWorks:ISDK::SetVertex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the vertex number vertexNum (1->numVerts) to have the value of vertex. vType can be one of vtCorner, vtBezier, vtCubic, vtArc and Coord arcRadius sets the radius of the vetex if it of VertexType == vtArc. If recalcBounds is false, the bounding box of the poly is not recalculated to reflect the changed coordinate values. This is useful when you are changing many points of a polygon (call ResetObject when you have finished).

virtual void SetVertex(
MCObjectHandle h,
short vertexNum,
const WorldPt& vertex,
VertexType vType,
WorldCoord arcRadius,
bool recalcBounds = true)

Parameters

MCObjectHandle h No information available.
short vertexNum No information available.
constWorldPt& vertex No information available.
VertexType vType No information available.
WorldCoord arcRadius No information available.
boolrecalcBounds= true No information available.

Version

Availability: from Vectorworks 2009