VCOM:VectorWorks:ISDK::SetUserOriginFP

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the current origin of the drawing as an offset from the center of the page. Uses Floating point parameter. If the origin could not be set as specified, false is returned and the origin is set to (0,0).

virtual bool SetUserOriginFP(
const WorldPt& inOrigin)

Parameters

constWorldPt& inOrigin No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009