VCOM:VectorWorks:ISDK::SetUndoMethod

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the method of undo to one of the kUndo types listed below:

  • kUndoNone (0) disables undo for the duration of the plug-in and clears the undo table. (It is sometimes advisable to precede this type of call with a NonUndoableActionOK call to allow the user a chance to back out of the operation.)
  • kUndoSwapObjects (21) allows customization of the objects to be replaced using AddBeforeSwapObject, AddAfterSwapObject, and AddBothSwapObjects.
  • kUndoReplaceSelection (17) saves the objects currently selected. When undo is selected, the selection at that time is replaced with the saved selection.
virtual void SetUndoMethod(
short undoType)

Parameters

short undoType No information available.

Version

Availability: from Vectorworks 2009