VCOM:VectorWorks:ISDK::SetSingularConstraint

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets a constraint on a single object. The valid values for type are 4 (vertical), 5 (horizontal), 8 (distance), 9 (vertical distance), 10 (horizontal distance) and 11 (radius). vertexA and vertexB indicate which vertices of the object define the geometry to be constrained. A value of -1 indicates that a vertex parameter is not applicable. It returns false if the constraint cannot be set.

virtual bool SetSingularConstraint(
short type,
MCObjectHandle obj,
short vertexA,
short vertexB)

Parameters

short type No information available.
MCObjectHandle obj No information available.
short vertexA No information available.
short vertexB No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009