VCOM:VectorWorks:ISDK::SetShedAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Set the settings of a shed style dormer.


dormerID: Identifies the dormer for which to set the information.


useHeight: true if the next value is the height of the dormer, if false, next value is the depth (front to back) of the dormer

heightDepthValue: size of the dormer, either by height or depth; determined by previous parameter.


bottomWidth: Dimension of bottom front edge of the dormer, left to right.


topSlope: Angle of dormer roof.


overhang: Distance roof projects past dormer walls.

virtual bool SetShedAttributes(
MCObjectHandle object,
const short dormerID,
bool useHeight,
WorldCoord heightDepthValue,
WorldCoord bottomWidth,
double_param topSlope,
WorldCoord overhang)

Parameters

MCObjectHandle object No information available.
constshort dormerID No information available.
bool useHeight No information available.
WorldCoord heightDepthValue No information available.
WorldCoord bottomWidth No information available.
double_param topSlope No information available.
WorldCoord overhang No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009