VCOM:VectorWorks:ISDK::SetProjection

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Changes the projection of the specified layer to newProj. If confirmWithUser is true, then the user will be asked if they want to continue if a long re-render is invoked as a result of the projection change. Otherwise, the re-render will proceed without a dialog. When doProgress is set, any re-rendering necessary displays the normal series of rendering progress indicators in the mode bar.

virtual void SetProjection(
MCObjectHandle theLayer,
short newProj,
bool confirmWithUser,
bool doProgress)

Parameters

MCObjectHandle theLayer No information available.
short newProj No information available.
bool confirmWithUser No information available.
bool doProgress No information available.

Version

Availability: from Vectorworks 2009