VCOM:VectorWorks:ISDK::SetProgramVariable

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

SetProgramVariable sets general program information based on the selector passed. If the selector is not recognized, nothing is unchanged and false is returned. value should be a pointer to a variable of the correct size for the passed selector (for example, a pointer to a boolean when using the varBlackBackground selector). A list of recognized selectors is found in MiniCadCallBacks.h.

virtual bool SetProgramVariable(
short variableSelector,
const void* value)

Parameters

short variableSelector No information available.
constvoid* value No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009