VCOM:VectorWorks:ISDK::SetMarker

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the markers of a segment or arc. This function supercedes SetArrowHeads. The size parameter is the number of 1/16384 ths of an inch that you desire the marker to be. For a one inch marker pass in a size value equal to 16384. If you pass NIL for the obj parameter, this call will set the marker defaults for this document. The angle parameter must be in range 0 to 90 degrees.

virtual void SetMarker(
MCObjectHandle obj,
MarkerType style,
short size,
short angle,
bool start,
bool end)

Parameters

MCObjectHandle obj No information available.
MarkerType style No information available.
short size No information available.
short angle No information available.
bool start No information available.
bool end No information available.

Version

Availability: from Vectorworks 2009