VCOM:VectorWorks:ISDK::SetHatchLevel

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the indicated level of the hatch definition to the parameters specified: startPt and repeatVec define a line, dashFactor indicates what fraction of the line is drawn (0.0 to 1.0), offsetVec is an offset from startPt to the next parallel line. If the indicated level doesn't exist but level-1 does exist, then the level is created, else if the level exists it is modified, else the function returns false. The index starts at 0.

virtual CBbool SetHatchLevel(
MCObjectHandle inHatchDef,
short inLevel,
const WorldPt& inStartPt,
const WorldPt& inRepeatVec,
double_param inDashFactor,
const WorldPt& inOffsetVec,
ColorRef inColorIndex,
short inMilsLineWeight)

Parameters

MCObjectHandle inHatchDef No information available.
short inLevel No information available.
constWorldPt& inStartPt No information available.
constWorldPt& inRepeatVec No information available.
double_param inDashFactor No information available.
constWorldPt& inOffsetVec No information available.
ColorRef inColorIndex No information available.
short inMilsLineWeight No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009