VCOM:VectorWorks:ISDK::SetComponentOffsetFromWallTop

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the offset from wall top of a component in an object.

virtual Boolean VCOM_CALLTYPE SetComponentOffsetFromWallTop(
MCObjectHandle object,
short componentIndex,
WorldCoord offsetFromWallTop) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex short The index of the component.
offsetFromWallTop WorldCoord The offset from wall top of the component.

Version

Availability: from Vectorworks 2010