VCOM:VectorWorks:ISDK::SetComponentFollowTopWallPeaks

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the follow top wall peaks flag of a component in an object.

virtual Boolean VCOM_CALLTYPE SetComponentFollowTopWallPeaks(
MCObjectHandle object,
short componentIndex,
Boolean followTopWallPeaks) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex short The index of the component.
followTopWallPeaks Boolean Whether or not the component will follow top wall peaks.

Version

Availability: from Vectorworks 2010