VCOM:VectorWorks:ISDK::SetComponentClass

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the class of a component in an object.

virtual Boolean VCOM_CALLTYPE SetComponentClass(
MCObjectHandle object,
short componentIndex,
long componentClass) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
componentClass long The class of the component.

Version

Availability: from Vectorworks 2009