VCOM:VectorWorks:ISDK::SetBinaryConstraint

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets a constraint between two objects or two parts of a single object. Valid values for type are 1 (coincident), 2 (colinear), 3 (parallel), 6 (tangent), 7 (concentric), 8 (distance), 9 (horizontal distance), 10 (vertical distance), 12 (angle) and 13 (perpendicular). obj1VertexA and obj1VertexB indicate which vertices of the first object to use in the constraint, and obj2VertexA and obj2VertexB indicate which vertices of the second object to use. A value of -1 indicates that a vertex parameter is not applicable. The containedObj fields are for an index into the list of a container object such as a symbol. This can be obtained from the GetClosestPt function. If the constraint cannot be set, it returns false.

virtual bool SetBinaryConstraint(
short type,
MCObjectHandle obj1,
MCObjectHandle obj2,
short obj1VertexA,
short obj1VertexB,
short obj2VertexA,
short obj2VertexB,
long containedObj1,
long containedObj2)

Parameters

short type No information available.
MCObjectHandle obj1 No information available.
MCObjectHandle obj2 No information available.
short obj1VertexA No information available.
short obj1VertexB No information available.
short obj2VertexA No information available.
short obj2VertexB No information available.
long containedObj1 No information available.
long containedObj2 No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009