VCOM:VectorWorks:ISDK::SetAsPolyBreak

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Available in VW Architect only. Takes the given polyline and uses it to set a polybreak at the given breakIndex. The polyline object is converted to a polyBreak object and placed in the wall aux list. The input polyline must be a stand alone object (not in the drawing or any other list)

virtual void SetAsPolyBreak(
MCObjectHandle& thePolyline,
MCObjectHandle theWall,
short breakIndex)

Parameters

MCObjectHandle& thePolyline No information available.
MCObjectHandle theWall No information available.
short breakIndex No information available.

Version

Availability: from Vectorworks 2009