VCOM:VectorWorks:ISDK::ReadVSExternalFilePath

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Private callback for use by Nemetschek North America Workspace external only.

Given a full pFileID, this callback will open the file and determine if it is a MiniPascal External file.

If so, it will read in a portion of its contents and return the data in the argument outData.

virtual bool VCOM_CALLTYPE ReadVSExternalFile(
IFileIdentifier* pFileID,
TMPExternalDataForWorkspace& outData) = 0;

Parameters

pFileID IFileIdentifier* The VectorScript file.
outData TMPExternalDataForWorkspace& Output parameter. <no info>

Version

Availability: from Vectorworks 2009