VCOM:VectorWorks:ISDK::Project3DModelPtToScreen

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Projects the given 3D world point to the Screen plane, and returns a 2D point. It is a good idea to confirm if the return value is true, before using the converted 2D point.

virtual BooleanVCOM_CALLTYPE Project3DModelPtToScreen(
const WorldPt3& inwpt3Model,
WorldPt& outwptScreen) = 0;

Parameters

inwpt3Model const SDK:WorldPt3& no info.
outwptScreen SDK:WorldPt& no info.

Version

Availability: from Vectorworks 2014