VCOM:VectorWorks:ISDK::PreviewDrawFrame

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This is a call for interactive rotation of 3D objects. This call is used to produce behavior the user sees when using 3D view specification tools like walkthrough and flyover. To use this service, first get the current view matrix with GetViewMatrix. Then create a preview with PreviewSetup. You can then repeatedly modify the matrix, call SetViewMatrix and call PreviewDrawFrame in a loop until the desired view is chosen. The view change would typically respond to input from the user, but QuickTime export uses the same calls to display animation previews. You must then call PreviewFinish, and if you want to permanently alter the view, you must call NewCurrentViewMatrix to set the new view.

virtual void PreviewDrawFrame(
Handle thisPreview,
bool selectedOnly = false)

Parameters

Handle thisPreview No information available.
boolselectedOnly= false No information available.

Version

Availability: from Vectorworks 2009