VCOM:VectorWorks:ISDK::NurbsGetWeight

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

returns the weight for the index2 control point of the index1 piece of nurbs curve or for the indexU row and the indexV column control point of nurbs surface

virtual bool NurbsGetWeight(
MCObjectHandle nHandle,
long index1,
long index2,
double& weight)

Parameters

MCObjectHandle nHandle No information available.
long index1 No information available.
long index2 No information available.
double& weight No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009