VCOM:VectorWorks:ISDK::LineLineIntersect

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Calculates the intersection between the two lines specified. Parallel is set if no intersection could be found because the lines are parallel. intOnLine is set if the intersection is between the endpoints of both lines.

virtual void LineLineIntersect(
const WorldPt& a1,
const WorldPt& a2,
const WorldPt& b1,
const WorldPt& b2,
bool& parallel,
bool& intOnLines,
WorldPt& sect)

Parameters

constWorldPt& a1 No information available.
constWorldPt& a2 No information available.
constWorldPt& b1 No information available.
constWorldPt& b2 No information available.
bool& parallel No information available.
bool& intOnLines No information available.
WorldPt& sect No information available.

Version

Availability: from Vectorworks 2009