VCOM:VectorWorks:ISDK::JoinWalls

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This function provides an interface to the wall join tool. Input two walls and a point on each wall, specify a join type, and set the capped flag.


Join Modifier Types: kTWallJoin, kLWallJoin, kXWallJoin, kAutoWallJoin, kAutoLWallJoin

virtual bool JoinWalls(
MCObjectHandle firstWall,
MCObjectHandle secondWall,
const WorldPt& firstWallPt,
const WorldPt& secondWallPt,
JoinModifierType joinModifier,
bool capped,
bool showAlerts)

Parameters

MCObjectHandle firstWall No information available.
MCObjectHandle secondWall No information available.
constWorldPt& firstWallPt No information available.
constWorldPt& secondWallPt No information available.
JoinModifierType joinModifier No information available.
bool capped No information available.
bool showAlerts No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009