VCOM:VectorWorks:ISDK::InsertNewComponent

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Inserts a new component in an object.

virtual Boolean VCOM_CALLTYPE InsertNewComponent(
MCObjectHandle object,
short beforeComponentIndex,
WorldCoord width,
long fill,
Uint8 leftPenWeight,
Uint8 rightPenWeight,
Sint8 leftPenStyle,
Sint8 rightPenStyle) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
beforeComponentIndex short The index before which to insert the new component.
width WorldCoord The width of the component.
fill long The fill of the component. Positive values for patterns, negative ref numbers for hatches.
leftPenWeight Uint8 The pen weight of the component's left line.
rightPenWeight Uint8 The pen weight of the component's right line.
leftPenStyle Sint8 The pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle Sint8 The pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Version

Availability: from Vectorworks 2009