VCOM:VectorWorks:ISDK::GetWorksheetCellString

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the specified worksheet cell's displayed string.

If the cell contains a string, the displayed string IS that string.

If the cell contains a number, the displayed string is that number PLUS any formatting applied to that number.

Use IsWorksheetCellString and/or MP_IsWSCellNumber to determine what type of value the cell actually contains.

Use GetWorksheetCellValue to retrieve actual numerical value without formatting from a cell that contains a number.

virtual void GetWorksheetCellString(
MCObjectHandle worksheet,
const Point& cell,
const TXString& cellString)

Parameters

MCObjectHandle worksheet No information available.
constPoint& cell No information available.
constTXString& cellString No information available.

Version

Availability: from Vectorworks 2009