VCOM:VectorWorks:ISDK::GetTrapeziumAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the settings of a trapezium style dormer. This will fail if the dormerID identifies a dormer of a different style, or the dormerID is not valid.


dormerID: Identifies the dormer for which to retrieve the information.


useHeight: true if the next value is the height of the dormer, if false, next value is the depth (front to back) of the dormer.

heightDepthValue: size of the dormer, either by height or depth; determined by previous parameter.


bottomWidth: dimension of bottom front edge of the dormer, left to right.


useTopWidth: true if using a dimension to set the width of the dormer roof. False if the top width of the dormer is determined by the left and right slope. The topWidth is exclusive of leftSlope & rightSlope.

topWidth: dimension of the roof of the dormer.

leftSlope: angle of left dormer wall.

rightSlope: angle of right dormer wall.

topSlope: angle of the roof of the dormer.

virtual bool GetTrapeziumAttributes(
MCObjectHandle object,
const short dormerID,
bool& useHeight,
WorldCoord& heightDepthValue,
WorldCoord& bottomWidth,
bool& useTopWidth,
WorldCoord& topWidth,
double_gs& leftSlope,
double_gs& rightSlope,
double_gs& topSlope)

Parameters

MCObjectHandle object No information available.
constshort dormerID No information available.
bool& useHeight No information available.
WorldCoord& heightDepthValue No information available.
WorldCoord& bottomWidth No information available.
bool& useTopWidth No information available.
WorldCoord& topWidth No information available.
double_gs& leftSlope No information available.
double_gs& rightSlope No information available.
double_gs& topSlope No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009