VCOM:VectorWorks:ISDK::GetTextCustomStyle

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This function returns the custom style for the indicated character in the passed in text object. If the value is 32, the character is displayed as a superscript. If the value is 64, the character is displayed as a subscript. Otherwise the character is displayed normally.

virtual voidVCOM_CALLTYPE GetTextCustomStyle(
MCObjectHandle textBlock,
long charNum,
unsigned char& customStyle) = 0;

Parameters

textBlock MCObjectHandle The text object for which the custom style is desired.
charNum long The index of the character for which the custom style is desired.
customStyle unsigned char& The returned value: 0 = normal, 32 = superscript, 64 = subscript.

Version

Availability: from Vectorworks 2010