VCOM:VectorWorks:ISDK::GetTextCharsToBuffer

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This is identical to GS_GetTextChars except it returns the text in a buffer passed by the client rather than a handle. The client should allocate a buffer large enough to contain the desired text and pass the size of the buffer in the bufferSize parameter. If the buffer is large enough, the text followed by a null character will be copied into the buffer, bufferSize will be set to the number of characters copied not including the null, and the function result will be true. If the buffer is smaller than the text to be copied, the buffer will be filled with as many characters as possible followed by a null character, bufferSize will be set to the size of buffer required to hold the full text block and the subsequent null character, and the function result will be false. If there is a parameter error the result will be false and bufferSize will be set to zero. If this call is used with a version of MiniCAD which does not support this callback (any version before MiniCAD 8.0.0), then the function will return false and the bufferSize parameter will be unchanged.

virtual bool GetTextCharsToBuffer(
MCObjectHandle textBlock,
void* buffer,
long& bufferSize)

Parameters

MCObjectHandle textBlock No information available.
void* buffer No information available.
long& bufferSize No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009