VCOM:VectorWorks:ISDK::GetSweepAnglesN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the angles that define a sweep. startAngle is the angle that the sweep begins, with 0 degrees; lying along the x-axis in entity space. arcAngle is how many degrees from the startAngle the sweep revolves. incrAngle is how many degrees between facets of the sweep.

virtual void GetSweepAnglesN(
MCObjectHandle theSweep,
double_gs& startAngle,
double_gs& arcAngle,
double_gs& incrAngle)

Parameters

MCObjectHandle theSweep No information available.
double_gs& startAngle No information available.
double_gs& arcAngle No information available.
double_gs& incrAngle No information available.

Version

Availability: from Vectorworks 2009