VCOM:VectorWorks:ISDK::GetSingularConstraint

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns a handle to a constraint node involving a single object of the indicated type on the specified vertices of the specified object. If the constraint does not exist, it returns 0.

virtual MCObjectHandle GetSingularConstraint(
short type,
MCObjectHandle obj,
short vertexA,
short vertexB)

Parameters

short type No information available.
MCObjectHandle obj No information available.
short vertexA No information available.
short vertexB No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009