VCOM:VectorWorks:ISDK::GetShedAttributes

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the settings of a shed style dormer. This will fail if the dormerID identifies a dormer of a different style, or the dormerID is not valid.


dormerID: Identifies the dormer for which to retrieve the information.


useHeight: Set to true if the next value is the height of the dormer, if false, next value is the depth (front to back) of the dormer

heightDepthValue: Size of the dormer, either by height or depth; determined by previous parameter.


bottomWidth: Dimension of bottom front edge of the dormer, left to right.


topSlope: Angle of dormer roof.


overhang: Distance roof projects past dormer walls.

virtual bool GetShedAttributes(
MCObjectHandle object,
const short dormerID,
bool& useHeight,
WorldCoord& heightDepthValue,
WorldCoord& bottomWidth,
double_gs& topSlope,
WorldCoord& overhang)

Parameters

MCObjectHandle object No information available.
constshort dormerID No information available.
bool& useHeight No information available.
WorldCoord& heightDepthValue No information available.
WorldCoord& bottomWidth No information available.
double_gs& topSlope No information available.
WorldCoord& overhang No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009