VCOM:VectorWorks:ISDK::GetRoofElementType

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the type of roof object from id.


Identifies the dormer for which to retrieve the information.

edgeIndex: Index to which roof face this skylight or dormer is placed. Value is one based.


isDormer: true if this object is a dormer, false if skylight

dormerType: if it is a dormer then:


1 for Trapezium Dormer

2 for Saddle Dormer

3 for Shed Dormer

4 for Slope Dormer

5 for Bat Dormer

virtual bool GetRoofElementType(
MCObjectHandle object,
const short dormerID,
short& edgeIndex,
bool& isDormer,
short& dormerType)

Parameters

MCObjectHandle object No information available.
constshort dormerID No information available.
short& edgeIndex No information available.
bool& isDormer No information available.
short& dormerType No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009