VCOM:VectorWorks:ISDK::GetRoofEdge

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get a vertex of the roof. Vertices define the outline of the roof and its characteristics. Vertices must progress in a counter clock wise direction, when viewed from a top view, otherwise the roof cannot be built.


index: Indexs have values between 1 and NVertices (See GetRoofVertices())

edgePt: Coordinate point for this edge

slope: pitch of this roof edge

projection: eave overhang

eaveHeight: eave height

virtual bool GetRoofEdge(
MCObjectHandle object,
short index,
WorldPt& vertexPt,
double_gs& slope,
WorldCoord& projection,
WorldCoord& eaveHeight)

Parameters

MCObjectHandle object No information available.
short index No information available.
WorldPt& vertexPt No information available.
double_gs& slope No information available.
WorldCoord& projection No information available.
WorldCoord& eaveHeight No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009