VCOM:VectorWorks:ISDK::GetProjection

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the projection index from the specified layer.

virtual short GetProjection(
MCObjectHandle theLayer)

Parameters

MCObjectHandle theLayer Handle to the layer which projection is to be returned.

Return Value

On error returns: -1

Projection values are:

const short kOrthogonal         = 0;
const short kPerspective        = 1;
const short kCavalierOblique45  = 2;
const short kCavalierOblique30  = 3;
const short kCabinetOblique45   = 4;
const short kCabinetOblique30   = 5;
const short kPlan               = 6;

Version

Availability: from Vectorworks 2009