VCOM:VectorWorks:ISDK::GetObjectVariable

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Retrieves the property of an object. The selector chooses which property will be retrived, and the value contains the property value upon return.

A list of all selectors can be found in "MiniCadCallBacks.h", starting somewhere in the middle of the file.

virtual bool GetObjectVariable(
MCObjectHandle theObject,
short setSelector,
TVariableBlock& value)

Parameters

MCObjectHandle theObject No information available.
short setSelector No information available.
TVariableBlock& value No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009