VCOM:VectorWorks:ISDK::GetObjectPlanarBounds

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Procedure GetObjectPlanarBounds returns the planar bounds for planar 2D objects. If the objects are on Screen plane, it returns the Screen bounding box. If the given object does not have any plane associated with it, it returns an empty WorldRectVerts.

virtual BooleanVCOM_CALLTYPE GetObjectPlanarBounds(
MCObjectHandle h,
WorldRectVerts& outBoxVerts) = 0;

Parameters

h MCObjectHandle no info.
outBoxVerts WorldRectVerts& no info.

Version

Availability: from Vectorworks 2010